jrswab

No-fluff tutorials and privacy-focused tools for the modern productivity-minded developer.


Blog


LSQ Reaches v1.0.0


Categories: [Technology]

Since first introducing LSQ, the response from terminal-loving Logseq users has been fantastic. Today, I'm excited to announce that LSQ has reached version 1.0.0 – a milestone that represents stability, reliability, and feature completeness for terminal-based journaling.

The Journey to v1.0.0

LS...

Continue Reading...


How To Install a Matrix Server (Synapse) on OpenBSD


Categories: [Technology], [How To], [OpenBSD]

After much trouble shooting for several days I finally got this working. :sweat_smile:

This setup uses Openbsd 7.1 and will use a reverse proxy via relayd.

SSL certs are not added directly into the synapse homeserver.yaml file in this setup.

Installation Steps

  1. Install synapse: doas pkg_...

Continue Reading...


How to Run Syncthing as a Daemon on OpenBSD


Categories: [Technology], [How To], [OpenBSD]

  1. Install Syncthing pkg_add syncthing
  2. Enable Syncthing rcctl enable syncthing
  3. Update Daemon flag vi /etc/rc.d/syncthing, add -home=/var/syncthing
  4. Run Syncthing once to create initial files: /etc/rc.d/syncthing start
  5. Stop Syncthing after after a few minutes: /etc/rc.d/syncthing stop
  6. U...

Continue Reading...


How To Extract Kindle Notes From The Web


Categories: [Technology], [How To]

Luckily, it's quite easy...

Continue Reading...


How To Mine Wownero: Junkie Jeff Hard Fork


Categories: [Technology], [How To]

Last Update: July 12, 2021

How to Mine Directly With Wownerod

  1. Download the latest version of wownero to your mining computer.
  2. Extract the download
  3. Change to the new directory
  4. Run wownerod --start-mining {YOUR-ADDRESS} --spendkey {SECRET-SPENDKEY} --mining-threads {NUMBER}
  5. When the b...

Continue Reading...


How to Get Keyboard Key Names on Linux


Categories: [Technology], [How To]

Having the name to a certain key on your keyboard comes in handy.

This is especially true for anyone using a tiling window manager.

Since they often use keyboard shortcuts to execute actions.

It may be obvious that the name for the "a" key on your keyboard is "a". But what about "left shift" o...

Continue Reading...


Virtues Of An Effective Programmer


Categories: [Technology]

The Virtues Of An Effective Programmer

  1. Be Lazy in an industrious way.
  2. Be Impatient in a very patient way.
  3. Be Huberistic in a very humble way.

It is said that Hobbits would make great programmers:

  1. Persistence - Stubbornness to keep slogging through when the going gets rough,
  2. Sm...

Continue Reading...


Why Algorithms Are Actually Sabotaging You


Categories: [Technology]

A vast majority of mentees I work with have this mentality.

They think they need to be able to whip out a sort algorithm from the back of their brain in an interview.

This is a complete waste of their time...

It's not their fault though... because this idea has been push out from the biggest...

Continue Reading...


How To Get Your First Programming Job


Categories: [Technology], [How To]

Most coding programs are great at getting people started coding, but leave the new programmer without the path to actually getting their first job.

Here's a great approach to having recruiters come to you and have the best chance at getting interviews.

First, only focus on what you can prove you...

Continue Reading...


Here’s Eric Raymond’s Secret to Be a Better Coder


Categories: [Technology]

"Computer science education cannot make anybody an expert programmer any more than studying brushes and pigment can make somebody an expert painter." Eric Raymond

Who is Eric Raymond?

He is an American software developer, open-source software advocate, and author of the 1997 essay and 1999 b...

Continue Reading...